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Einleitung

� Zeitrahmen
➜ 8:30 – 12:00 Uhr
➜ Pause 10:00 – 10:15 Uhr

� Ablauf
➜ Vortrag
➜ Anwendungsbeispiele

� Fragen
➜ Immer und jederzeit
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Agenda

� Das Konzept

� Grundlegende Beispiele
� Output Objekte
� Der Output Kanal
� Seitenkontrolle bei RTF/PDF/Printer
� HTML Ausgabe
� ODS und Graphiken
� ODS Styles
� ODS und Reporting Prozeduren
� Table & Style Templates

Literaturhinweise

� Haworth, Lauren E. (2001): Output Delivery System:
The Basics, Cary, NC. [Reihe Books by users]

� SAS OnlineDoc
➜ Im Lieferumfang enthalten
➜ Auch online verfügbar (mit Registrierung)

� www.sas.com
➜ SAS/BASE Community
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Das Konzept

SAS-Output vor ODS

� Zwei Formen
➜ Listing im Output-Fenster
➜ Ausgabe-Tabellen

� Nachteile
➜ Manche Prozeduren erzeugen keine Tabellen
➜ Nicht alle Informationen in Tabellen
➜ Statisch
➜ Beschränkung auf Proportional(?)-Schriftarten
➜ Keine echte Tabellenstruktur
➜ Übernahme in Textverarbeitung, Tabellenkalkulation,

Graphikprogramme schwer oder gar nicht möglich
➜ Hoher Nachbearbeitungsaufwand
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SAS-Output mit ODS

� WYSIWYG
➜ Alles was im OUTPUT-Fenster erscheint steht im ODS

zur Verfügung
➜ Alle Informationen aller Prozeduren

� Parallelisierung des Output
➜ Ergebnisse werden an viele Kanäle gleichzeitig geliefert

� Gliederung des Output
➜ Prozedur-Output wird in Objekte zerlegt
➜ Zugriff auf jedes einzelne Objekt möglich

ODS Ausgabe-Kanäle

� Listing Output-Fenster
� Output SAS-Tabelle
� HTML Dokument für WWW
� PDF Dokument für Acrobat Reader
� RTF Dokument für Textverarbeitung
� PRINTER Systemdrucker
� PS Postscript
� Experimental

➜ LateX
➜ XML
➜ ...
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Funktionsweise des ODS

Daten-
Komponente

Listing

SAS-Tabelle

HTML Dokument

RTF Dokument

PDF Dokument

Ausdruck

...

Table
Template

Output-Objekt

Kanal

Listing
Output
HTML
RTF
PDF

PRINTER
...

Style
Template

ODS-Syntax

� Globale Statements
➜ Voll batch-fähig

� Schalterprinzip
➜ Kanal wird geöffnet
➜ Output von Prozeduren/Data Steps
➜ Kanal wird geschlossen
➜ Ergebnis ist betrachtbar
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Öffnen und Schließen von ODS-Kanälen

� Öffnen eines Kanals
➜ Ods Kanal;
➜ Ods Kanal file=„“;
➜ Ods Kanal output-objekt=SAS-Tabelle;

� Schließen eines Kanals
➜ Ods Kanal close;
➜ Ods _all_ close;

� Grundprinzip
➜ Es muss mindestens ein Kanal geöffnet sein
➜ Ansonsten Warning im LOG-Fenster

Grundlegende Beispiele
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Ods Listing

� Ein-/Ausschalten
➜ Ods Listing;
➜ ...
➜ Ods Listing close;

� Beispiel01.sas

Ods Html

� Ein-/Ausschalten
➜ Ods Html file=fileref | „pfad“;
➜ ...
➜ Ods Html close;

� Beispiel02.sas
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Ods Pdf

� Ein-/Ausschalten
➜ Ods Pdf file = fileref | „pfad“;
➜ ...
➜ Ods Pdf close

� Beispiel03.sas

Ods Rtf

� Ein-/Ausschalten
➜ Ods Rtf file = fileref | „pfad“
➜ ...
➜ Ods Rtf close;

� Beispiel04.sas
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Ods Printer/PS

� Ein-/Ausschalten
➜ Ods Printer <display>;
➜ Ods PS file = fileref | „pfad“;
➜ ...
➜ Ods Printer/PS close;

� Beispiel05.sas

Mehrere Kanäle gleichzeitig verwenden

� Unterschiedliche Kanäle
➜ Ods Pdf file = fileref | „pfad“;
➜ Ods Html file = fileref | „pfad“;
➜ ...
➜ Ods _all_ close

� Beispiel06.sas
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Mehrere Kanäle gleichzeitig verwenden

� Gleiche Kanäle
➜ Ods Html (id=1) file = fileref || „pfad“;
➜ Ods Html (id=2) file = fileref || „pfad“;
➜ ...
➜ Ods Html (1) close;
➜ ...
➜ Ods Html (2) close

� Beispiel07.sas

Ods Grundeinstellungen

� Tools -> Options -> Preferences

� Tabber „Results“
➜ Ods Listing;
➜ Ergebnisse als HTML
➜ Style = default
➜ Web-Browser

� Umstellen unter Tabber „Web“
➜ Direkte Anzeige der Ergebnisse
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Output Objekte

� Ods teilt Prozedur-Output in Objekte ein
➜ Jedes Objekt ist identifizierbar
➜ Jedes Objekt ist einzeln ansprechbar

� Anzahl der Output Objekte ist abhängig von
➜ Prozedur
➜ Prozedur-Optionen
➜ By-Gruppen
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� Identifizieren von Output Objekten
➜ Ods Trace on;
➜ ...
➜ Ods Trace off;

� Inhalt des Trace-Satzes
➜ Name des Output Objektes
➜ Label des Output Objektes
➜ Name des verwendeten Table Templates
➜ Pfad des Output Objekts

� Beispiel08.sas

� Results-Fenster zeigt Output Objekte an

Auswahl von Output Objekten

� Select-/Exclude-Liste
➜ Enthält Auswahl von Output Objekten
➜ Eine globale Liste
➜ Eine Liste für jeden aktiven Kanal

� Anzeigen der Select-/Exclude-Liste
➜ Ods <Kanal> show;
➜ Dabei muss der Kanal muss aktiv sein

� Beispiel09.sas
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� Auswahl von Output Objekten
➜ Ods <Kanal> Select ods-objekt <ods-objekt ...>;
➜ Ods <Kanal> Exclude ods-objekt <ods-objekt ...>;
➜ Ods <Kanal> Select | Exclude all | none;
➜ Dabei kann ods-objekt sein

� Name aus Trace-Satz
� Pfad aus Trace-Satz
� Label aus Trace-Satz
� Mischung aus Label und Pfad

� Beispiel10.sas

Voreinstellungen der Auswahllisten

� Globale Select-/Exclude-Liste
➜ Select all

� Alle Bericht-Kanäle
➜ Select all

� Output-Kanal
➜ Exclude all

� Beispiel11.sas
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� Gültigkeitsdauer der Auswahl
➜ Nachfolgende Prozedur

� Option persist
➜ macht Auswahl eines Objektes dauerhaft
➜ muss mit neuem Statement überschrieben werden
➜ Ods <Kanal> Select | Exclude ods-objekt (persist);
➜ ...
➜ Ods <Kanal> Select all;

� Beispiel12.sas

Output Kanal
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Ods Output

� Ein-/Ausschalten
➜ Ods Output ods-objekt = SAS-Tabelle ...;
➜ ...
➜ Ods Output close;

� Beispiel13.sas

� Verarbeitung von By-Gruppen
➜ Standardverhalten:

alle By-Gruppen in eine Tabelle
➜ Match_all-Option:

Ods Output ods-objekt(match_all<=mVar>)= SAS-Tabelle;
jede By-Gruppe in eigene Tabelle
automatische Benennung
mVar enthält Namen der erzeugten Tabellen

� Beispiel14.sas
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� Verarbeiten mehrerer Prozeduren
➜ match_all + persist-Option
➜ Ods Output ods-objekt(match_all<=mVar

<persist=run|proc>>) = SAS-
           Tabelle;

➜ ...
➜ Ods Output close;
➜ Erhält Benennungsschema

Seitenkontrolle bei
RTF/PDF/PRINTER
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� Grundeinstellung
➜ Jede Prozedur beginnt neue Seite
➜ Innerhalb der Prozedur selbst keine Eingriffsmöglichkeit

� Seitenumbrüche steuern
➜ Startpage-Anweisung
➜ Ods Kanal startpage=off;

Schaltet automatischen Seitenumbruch nach Prozedur aus
➜ Ods Kanal startpage=on;

Schaltet automatischen Seitenumbruch nach Prozedur ein
➜ Ods Kanal startpage=now;

In Verbindung mit Ods Startpage off
erzwingt Seitenumbruch an bestimmter Stelle

� Beispiel15.sas

� Optionen für die Seitengestaltung
➜ Title Titel
➜ Footnote Fußnoten
➜ [no]Center linksbündig
➜ [no]Number keine Seitenzahlen
➜ [no]Date kein Datum
➜ Orientation = portrait| Hochformat

           landscape Querformat
➜ paperSize = A4 | (x,y) Seitengröße
➜ [left|right|top|bottom]Margin=n Randeinstellungen

➜ Funktionieren aber nicht immer mit allen Kanälen...

� Beispiel16.sas
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� Ods Statements für die Seitengestaltung
➜ notoc (Pdf) Kein Inhaltsverzeichnis

➜ bodyTitle (Rtf) Titel im Text (buggy)

� Title & Footnote
➜ Ähnlich SAS/GRAPH verwendbar

� Font = Schriftart
� Height = Schriftgröße
� Color = Farbe
� Justification = Ausrichtung

� Beispiel17.sas

HTML Ausgabe
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� Erstellen ganzer Web-Sites im batch
➜ Statische Reports als HTML
➜ Automatische Erzeugung von Framesets
➜ Verwendung von Cascading Style Sheets
➜ „Verlinken“ verschiedener Seiten
➜ Interaktive Graphiken
➜ Graphiken mit Hyperlinks
➜ Aufsplitten der Ergebnisse auf mehrere Dateien

� Was ist ein Frameset?
➜ Konzept in HTML
➜ Zeigt gleichzeitig mehrere HTML-Dateien an
➜ Unterteilt die Anzeige in verschiedene Bereiche (Frames)

� Mit Ods möglich
➜ ���� Inhaltsverzeichnis
➜ ���� Seitenverzeichnis
➜ ���� Hauptseite �

�

�
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� Erstellen eines Frameset mit ODS
➜ Ods html path = „verzeichnis“ (url=none)

   body = „name.html“
   contents = „name.html“
   page = „name.html“
   frame = „name.html“;

➜ Path: Pfad unter dem alle Dateien angelegt werden
➜ (url=none): Hyperlinks werden relativ angelegt
➜ Body: Hauptseite
➜ Contents: Inhaltsverzeichnis
➜ Page: Seitenverzeichnis
➜ Frame: Html-Seite, die den Frameset enthält

�  Beispiel18.sas

Unterstützung von Cascading Style Sheets

� Hintergrund
➜ HTML: tag-gesteuerte Layoutanweisungen, ASCII
➜ Dateien sollen möglichst klein sein
➜ Wie wird Layout definiert?

� Für jedes Element einzeln
� Definition von Klassen (Cascading Style Sheet)

� Verschiedene Möglichkeiten CSS zu verwenden
➜ Ods Html ... Css;

eingebettetes Stylesheet
➜ Ods Html ... stylesheet = „name.css“;

CSS wird erstellt
➜ Ods Html ... stylesheet = (url=„“);

vorhandenes Stylesheet wird benutzt

� Beispiel19.sas
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� Aufsplitten des Output
➜ HTML-Dateien sollten möglichst klein sein
➜ Grundeinstellung: aller Prozedur-Output landet in einer

Datei

� newFile-Option
➜ Ods Html ... newFile = Output | Page | Proc;
➜ Erstellt neue Dateien für

� Jedes Output Objekt
� Jede logische Seite
� Jede Prozedurausgabe

� Beispiel20.sas

� Eingriffsmöglichkeiten in das Inhaltsverzeichnis
➜ Ods Proclabel „text“;

Ändert die Hauptüberschrift
➜ Option contents = „text“ bei den Prozeduren Print, Report

und Tabulate (hier auch als Option im Table-Statement)
Ändert die Unterüberschrift(en)

➜ Ods noOptitle;
Unterdrückt den Prozedurspezifischen Titel

� Beispiel21.sas
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� HTML direkt verwenden
➜ Titel und Fußnoten dürfen HTML-Code enthalten
➜ 1. Zeichen muss „<“ sein!!

� Beispiel22.sas

� Corporate Design nutzen
➜ Notop

Keine HTML-Startsequenz
➜ nobot-Anweisungen

Keine HTML-Schlusssequenz

� Beispiel23.sas

Ods und Graphiken



23

� Rtf
➜ Scheint momentan noch nicht korrekt zu funktionieren
➜ TTFs gehen verloren
➜ -> Graphiken getrennt erstellen
➜ Devices wmf, emf, sasemf

� Beispiel24.sas

� Pdf
➜ Vortrag von Heinrich Stürzel

� HTML
➜ Pixel-Graphiken in GIF- bzw. JPEG-Format
➜ Werden als Referenz in Seite integriert (<IMG src=„“>)
➜ Ods Html ... Gpath = „verzeichnis“ (url=none);

setzt das Verzeichnis, in dem Graphiken gespeichert
werden

� SAS/GRAPH Treiber
➜ JPEG
➜ GIF

� Goptions xPixels = n yPixels = n [no]Transparency

� Beispiel25.sas
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� Spezielle SAS/GRAPH Treiber
➜ ActiveX
➜ Java
➜ Interaktive Graphiken mit diversen Möglichkeiten wie

� Anzeige von Werten
� Rotieren Strg + LMB
� Verschieben Alt + LMB
� Zoomen Shift + LMB
� Selektion Strg + Shift + LMB
� Umstellen des Graphiktyps Kontextmenü
� ...

� Beispiel26.sas

ODS Html & SAS/GRAPH

� Erweiterung der Graphik-Prozeduren
➜ Graphiken mit Hyperlinks versehen
➜ Option html=variable in den verschiedenen Statements

� Schritte zum Erstellen von gelinkten Graphiken
➜ 1. Tabelle mit Drillvariable erzeugen

variable = „href=name.html“;
➜ 2. Graphik erzeugen
➜ 3. Die Seiten auf die verwiesen wird erzeugen

� Beispiel27.sas
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ODS Styles

� Abstrakte Beschreibung von ODS-Elementen
➜ Dokument
➜ Inhaltsverzeichnis
➜ Seitenverzeichnis

� Layoutangaben
➜ Farben
➜ Schriftarten (Größe, Gestaltung)
➜ Tabellengestaltung (Abstände, Ränder)
➜ Beschriftung (z.B. des Inhaltsverzeichnisses)

� Werden immer verwendet
➜ HTML -> default
➜ RTF -> rtf
➜ PDF -> printer
➜ PRINTER/PS -> printer
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� Mitgelieferte Styles
➜ Default
➜ D3d
➜ Brick
➜ statDoc
➜ Minimal
➜ sasWeb
➜ barrettsBlue
➜ ...
➜ Tools -> Options -> Preferences -> Results Tabber

� Verwendung von Styles
➜ Ods Kanal style=name;

� Beispiel28.sas

ODS und Reporting
Prozeduren
Proc Print, Proc Report, Proc Tabulate
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� Neue Style-Option
➜ Style={style-anweisung ...};
➜ Style(element)={style-anweisung...};
➜ Überschreibt Layoutanweisungen des gewählten Styles

� Style Anweisungen (Auswahl)
➜ Background = Farbe
➜ Foreground = Farbe
➜ borderColor = Farbe
➜ Schriftart spezifisch

� Font_face= Schriftart
� Font_size= Schriftgröße
� Font_weight= Schrift-Gewichtung (normal/fett)
� Font_style= Darstellung (italic=kursiv)

➜ Zellenlayout
� Cellheight= Zellenhöhe
� Cellwidth= Zellenbreite
� Cellpadding= Randabstand innerhalb Zelle
� Cellspacing= Abstand zwischen Zellen
� Just= horizontale Ausrichtung
� Vjust= vertikale Ausrichtung

➜ Graphische Elemente
� backgroundImage= Hintergrundbild
� preImage= Bild vor Objekt
� postImage= Bild nach Objekt

➜ HTML spezifisch
� preHtml=
� postHtml=
� url=
� Flyover=
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� Ods & Proc Print
➜ Output in Elemente unterteilt
➜ Jedes Element kann einzeln gelayoutet werden
➜ Style-Angaben für

� Gesamt-Tabelle
� Spaltenüberschriften
� Obs-Spalte
� Datenbereich
� Einzelne Spalte
� Einzelne Zelle (Ampel-Funktion)

Achtung bei Formaten:
ODS verarbeitet formatierte Werte !!!

� Beispiel29.sas

� Ods & Proc Report
➜ Globale Angaben als Optionen in Prozeduraufruf

� Header
� Column

➜ Spaltenbezogene Angaben als Optionen im
Define-Block
� Header
� Column

� Beispiel30.sas
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� Ods & Proc Tabulate
➜ Verwenden der Style-Option in verschiedenen

Statements
➜ CLASS
➜ CLASSLEVEL
➜ VAR
➜ KEYWORD
➜ BOX-Option
➜ TABLE-Statement

� Beispiel31.sas

Table & Style Templates
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� Table Template
➜ Grund-Layout
➜ Aufteilung in Spalten
➜ Spaltenbeschriftung
➜ Zahlenformatierung
➜ Kann auch Style-Anweisungen enthalten

� Style Template
➜ Layout der Elemente
➜ Abhängig vom Kanal

� Objekt-orientierter Ansatz

� Verwaltung von Table & Style Templates
➜ Ods Template Viewer

� Kommando odsTemplate
� Results-Fenster

➜ Hierarchische Organisation in „itemstore“
� Defaults: Sashelp.tmplmst (schreibgeschützt)

� Eigene: Sasuser.Templat
➜ Anlegen eigener itemstores mit Proc Template
➜ Ods Suchpfad

� Ods Path show;
� Ods Path libref.itemstore(modus)

modus = read | update | write
� Ods Path

append | prepend | remove libref.itemstore(modus)
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� Table Templates verändern
➜ Beispiel Proc Univariate: Extreme Observations
➜ Beschriftung eindeutschen
➜ Wird in sasuser.templat gespeichert

� Beispiel32.sas

� Style Templates anpassen
➜ Neuen Style ableiten
➜ Gewünschte Änderungen vornehmen

� Aufbau des Styles default
➜ Definition von Schriftarten
➜ Definition von Farben
➜ Definition der einzelnen Elemente
➜ Hierarchie in OnlineDoc beschrieben

Base SAS Software
    -> Guide to the SAS Output Delivery System
        -> Reference
            -> The TEMPLATE Procedure
                -> Concepts

� Beispiel33.sas
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� Data Step Reporting & Table Templates
➜ Mit Table Templates Schablonen entwerfen

� Spaltenlayout
� Beschriftung
� Style-Anweisungen
� Ampelfunktion mit Hilfe von

� Cellstyle-Anweisung
� Style-Anweisung + Expression-Funktion
� Style-Anweisung + Format

� Berechnete Spalten
� Verändern von Werten

� Beispiel34.sas – Beispiel38.sas

Noch Fragen?

Sollten Sie Fragen oder Anregungen haben wäre ich für eine
email dankbar.

Grischa_pfister@info-ware.de


